centos8安装docker遇到问题解决:

  |   0 评论   |   0 浏览

问题: containerd.io版本太低

[root@smite ~]# sudo yum install docker-ce docker-ce-cli
Last metadata expiration check: 0:13:34 ago on Mon 16 Dec 2019 01:10:30 PM CST.
Package docker-ce-cli-1:19.03.4-3.el7.x86_64 is already installed.
Error: 
 Problem: package docker-ce-3:19.03.5-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package containerd.io-1.2.10-3.2.el7.x86_64 is excluded
  - package containerd.io-1.2.2-3.3.el7.x86_64 is excluded
  - package containerd.io-1.2.2-3.el7.x86_64 is excluded
  - package containerd.io-1.2.4-3.1.el7.x86_64 is excluded
  - package containerd.io-1.2.5-3.1.el7.x86_64 is excluded
  - package containerd.io-1.2.6-3.3.el7.x86_64 is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

解决办法:

参考资料


标题:centos8安装docker遇到问题解决:
作者:SmiteLi
地址:https://smite.site/articles/2019/12/16/1576474955600.html